Writer's Help 2.0 > How can I import scores for activities done outside of Writer's Help 2.0?

Document created by Digital Support on Jan 25, 2017Last modified by Digital Support on Nov 28, 2017
Version 11Show Document
  • View in full screen mode

In this article, we'll learn how to add scores to the Gradebook from activities that students completed outside of Writer's Help 2.0. Such activities might include: in-class quizzes/exams, class participation points, informal writing, or peer review.


First, we will show how to add an HTML Page (which is needed to incorporate any of the above activities) to Writer's Help. Then we will show how to export and import your scores/grades for that activity.


From the Table of Contents

Click + Add New Content.



Click on the image to zoom in.
 

From the drop-down menu, click Create New.



Click on the image to zoom in.
 

Click HTML Page.



Add item to course

If you do not see the Edit button or Basic Info tab right away, you may need to click Add to course at the top right of the screen.


Click on the image to zoom in.
 

Then, click Options > Edit on the HTML Page in your course to edit it.



Click on the image to zoom in.
 

Create HTML Page

Enter a Title, Subtitle (if desired), and Directions for your assignment. The Directions will become the body of your assignment, so enter any desired text, images, or links here. Then, click Save.

 


Click on the image to zoom in.


Click "Done Editing"

Click Done Editing in the upper left corner of the screen. You will see a preview of the HTML page you created.



 

Click "Home"

Click Home to return to your course home page.


 

Your HTML Page appears in the Table of Contents under the first chapter. If you wish, you can move it to another location in the Table of Contents. The next steps will go over that procedure.

 


Click on the image to zoom in.
 

From the Table of Contents, move your activity

Open the chapter in the Table of Contents where you would like the new HTML Page to be. Drag and drop the yellow bar (representing the HTML Page) to the desired location.


 

Your HTML Page is now located in the desired chapter of the Table of Contents.


 

From the Table of Contents, assign your activity

Hover your cursor over HTML Page in the Table of Contents, then click on the Options tab.


 

Click Assign.


 

From the "Manage Assignment" screen

  1. From the drop-down menu, select an assignment unit for your assignment. You can also create a new assignment unit by clicking Create New. For more information on this, please see the help article How do I create assignments?.
  2. Set a Due Date and time, if you wish.
  3. By default, your assignment will be visible to students. Uncheck the box Visible to students if you want the assignment to be hidden. You will be able to make it visible again later.
  4. Enter the number of Points for this assignment in the Gradebook section.
  5. Click Assign.

 

The blue To Do bar shows your assignment has been added to the Table of Contents.


 

From your home page, click "Gradebook"

When you’re ready to enter grades for this assignment, you can do so in two ways:

  1. By manually entering the grades
  2. By importing the grades from a .csv file


Whichever way you choose, you can do this from your Gradebook.



Click on the image to zoom in.
 

Enter grades manually

In your Gradebook, you should now have a column for the assignment. If you want to enter the grades manually, you can click on the grade column next to each student and enter in the correct point value. The cursor will automatically move from student to student down the list in the gradebook. 



Click on the image to zoom in.
 

Import grades from a .csv file

If you have grades recorded outside of Writer's Help (for example, in an Excel document), you can import them into your Writer's Help Gradebook. Here are the steps at a glance:

  1. Export your Writer's Help Gradebook into a .csv file.
  2. Add your scores to this file.
  3. Import the .csv file into your Writer's Help Gradebook.
 

Export your Writer's Help Gradebook

The Export Scores window will open and will display several pieces of information that you have the option of exporting from your Writer's Help Gradebook into a .csv file. We'll walk through each section of the Export Scores window and highlight the selections most of our instructors make. Click Export Scores.


 

Select Student Information, Item Information, and Item Data

To quickly import scores you're currently keeping outside your Writer's Help Gradebook, select only the items you need. For example:

  1. To identify your students, under Student Information, select First Name, Last Name, Grade, and any other information you would like.
  2. To identify one or more offline assignments or activities for which you wish to import grades – under Item Information, select Title.
  3. To dictate whether assignment scores should display as number of points or a percentage, under Item Data tick Points or Percent, respectively.
  4. To export your entire Gradebook, tick ALL under Items Selection. Click the + next to the All folder to view and select or de-select categories you wish to include or exclude. Click the + next to a category folder to expand it and select or de-select individual assignments you wish to include or exclude.
  5. Your File name will be "Grades" by default. You can change it to whatever you like. Again, by default, your grades will be exported into a .csv file, but you can drop the File type menu down to select Tab-separated file (.txt).

 

Select what program you would like to open the csv file with (for example: Excel, Open Office, or Google Docs). Then click OK.


 

Copy and paste scores into the .csv file

You now have an exported Gradebook. Simply copy the grades from each of your offline assignments or activities and paste them into the appropriate grade column.



Click on the image to zoom in.
 

Save your .csv file changes from Excel or similar program

Click File > Save As to select the type of file (if different from .csv).


 

Navigate to the folder location where you wish to store your offline/activity grades. Name your file. Then, click Save.


 

Save your changes in your .csv file

When you save the changes you made to the Gradebook, you may get a message that looks similar to the screen shot below. Click Yes to save in CSV format.


 

Return to your Writer's Help Gradebook and click "Import Scores"

To import the new grades into Writer's Help, return to your Gradebook and click Import Scores at the top of the page.



Click on the image to zoom in.
 

Choose the file to import

Click Choose File and select the Gradebook .csv file you exported and edited. If your file included a header, such as one or more assignment titles, make sure to check the box next to Header Row. When you are ready, click Continue.


 

Select csv file

Navigate to where your offline/activity grades are located. Select the file and click Open.



Click on the image to zoom in.
 

On the screen that appears, verify the information you are uploading is correct. When you are ready, click Continue.


 

Click "Import"



Click on the image to zoom in.
 

Green check marks will appear in the OK column, verifying that the information was successfully imported. Click Close


 

View imported grades in your gradebook



Attachments

    Outcomes