LaunchPad, FlipIt > What are the minimum system requirements for your media?

Version 7Show Document
  • View in full screen mode

Supported Browsers

We recommend the following browsers:

  • Chrome 28 and above
  • Firefox 13 and above
  • Safari 6 and above
  • Internet Explorer 10 and above
 

Mobile devices

Because our rich media runs on Flash, iPads, iPods, iPhones, and other mobile devices are not supported. Using an unsupported device or browser may prevent you from registering, logging in, navigating the site, assigning items, and submitting answers to a quiz. 

 

Pop-ups

We do use pop-ups, especially during the process of completing an online purchase to one of our sites.

  • Higher Learning instructors and students: Allow pop-ups on www.macmillanlearning.com.
  • High school teachers and students: Allow pop-ups on www.highschool.bfwpub.com.
 

Cookies

You must allow session cookies.

 

Java

JavaScript must be enabled (usually enabled by default). Click the following link for instructions on how to enable JavaScript in Chrome, Firefox, Safari, and Internet Explorer.

 

Multimedia requirements

  • Animations and interactive tutorials for some titles require Adobe Flash Player version 10 or higher (We recommend, however, using version 11 or the most current version available.)
  • To view PDFs, you will need the latest version of Adobe Reader.
  • Various video players/codecs depending on title: Brightcove, Apple QuickTime, Windows Media Player, RealPlayer, OggVorbis.
  • Some content requires Microsoft Office (Word, Excel, Powerpoint).
 

Monitor Resolution and Color Depth

1024x768 minimum required; larger resolutions are recommended.


1 person found this helpful

Attachments

    Outcomes