.NET Framework Requirements for iClicker Cloud on Windows 7

Document created by Digital Support on Jul 17, 2017
Version 1Show Document
  • View in full screen mode
The iClicker Cloud Instructor application can be run on any PC running Windows 7 or newer with a .NET Framework v4.5 or higher. If you do not have at least .NET 4.5 installed, the iClicker Cloud application will not run.

Windows 7 originally shipped with .NET 3.5, but can be updated to .NET 4.5 (released in 2012) with a free download. Starting with Windows 8, the system ships with .NET 4.5 framework or newer. Therefore, if you are a Windows 7 user you may need to update your .NET framework.

To determine which version of .NET is installed in your PC, click here.

To update your .NET framework to .NET 4.5.2, click here.

Attachments

    Outcomes