LaunchPad > How do I add slides to my video assessment program using slide sync?

Document created by Digital Support on Jan 4, 2018Last modified by Digital Support on Jan 10, 2018
Version 4Show Document
  • View in full screen mode

What is Slide Sync?

Slide Sync allows you to add PDF slides to your assignment in LaunchPad. You can set the timing for each slide transition and rearrange slides as needed. (See below for how to convert your slides to PDF.)

Note: Slide Sync is only available for Presenter Self-Record and Live Record activities and must be enabled by your instructor in the activity settings before you can add a slide deck.

Converting slides to PDF

First, export your slides as a PDF file by following the instructions below for your presentation software.


To convert your PowerPoint slides to PDF, please see Microsoft's guide.


To convert your Keynote slides to PDF, please see Apple's guide.

Google Slides

To convert your Google Slides to PDF, click File > Download as and select PDF. Then select Save.

Adding slides and transitions as you record your presentation

  1. Click the red Create Video button at the top right.
  2.  Under Slide Deck, click the +PDF Slides button and choose your file, then click Start.
User-added image
  1. Once the file has finished uploading and processing, click Continue.


Setting the timing of your slides

Click Got it! on the recording instructions, click Got it! over the Slide Sync explanation, then click Begin to start your recording.

Click on the image to zoom in.
  • During your presentation, click the arrow buttons (1) on either side of your slide deck preview on the left, whenever you want a transition to occur. You can also click on the Previous and Next (2) previews below the main PDF display. Timings are automatically saved as you go.
  • When you're finished, click End to stop your recording, then Exit to post your video. 

Adding your slides after recording or uploading

If you have already recorded and/or uploaded your video to LaunchPad you can add your slides to your submission in two ways:

From the playback screen for your video

Click on the image to zoom in.
  1. At the top of the video panel, click the Add Slide Deck button  (5).
  2. Click Choose a PDF file, browse to your file and click Open.
  3. Click Start to upload your file.
  4. Once the upload is complete, you can add your slide transitions. (See Set the timing of your slides below.)

From your Video Assessment Program activity dashboard

  1. Select your video on the dashboard and open the Edit menu by clicking the three dots on the right and selecting Edit
  2. Click the +PDF Slides button and Choose a PDF file.
  3. Browse to your file, select it, and click Open
  4. Click Start to upload your file. 
  5. Once the upload is complete, click Save.

Set the timing of your slides

  1. Enter the playback screen for your video.
  2. Above your recording, click the toggle next to Edit Slide Timings. (3)
  3. As your video plays, click the arrow keys to add transitions as needed. Each will be automatically saved as you go.
  4. Click Done at the bottom right when you are finished.

Deleting your slide deck

You can delete your slide deck from the playback window by enabling Edit Slide Timings (3) and clicking Delete Slide Deck(4) or by selecting your video in the dashboard, clicking Edit from the Edit menu on the right (three vertical dots), and clicking the red "X" on the PDF preview.

Changing your slides or their timing

To adjust the timing or change the order of your slides you can edit them from the playback screen.

Changing slides

  1. Enter the playback screen for your video.
  2. Click the Edit Slide Timings (3) toggle (red indicates you are in edit mode).
  3. Select a slide entry from the right and click the Edit  icon.
  4. Use the left and right arrow buttons to change the slide that you wish to use at this point.
  5. Click the green check mark  to Save.

Changing slide time codes

  1. To change the timing of your slide, click the Edit  icon and then click on the time code to the left of the slide entry. (6)
  2. Drag the slider or click the + or - buttons until you reach the desired time. 

  1. Click the green check mark  to save your changes.